summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am76
1 files changed, 76 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..a4521a7
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,76 @@
+# weipub - Teeny tiny activitypub thing
+# Copyright © 2022 Ricardo Wurmus <rekado@elephly.net>
+#
+# This program is free software: you can redistribute it and/or
+# modify it under the terms of the GNU Affero General Public License
+# as published by the Free Software Foundation, either version 3 of
+# the License, or (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# Affero General Public License for more details.
+#
+# You should have received a copy of the GNU Affero General Public
+# License along with this program. If not, see
+# <http://www.gnu.org/licenses/>.
+
+include guile.am
+
+moddir=$(prefix)/share/guile/site/$(GUILE_EFFECTIVE_VERSION)
+godir=$(libdir)/guile/$(GUILE_EFFECTIVE_VERSION)/site-ccache
+
+SOURCES = \
+ weipub/config.scm \
+ weipub/database.scm \
+ weipub/accounts.scm
+
+info_TEXINFOS = doc/weipub.texi
+
+TEST_EXTENSIONS = .scm
+
+SCM_TESTS = \
+ tests/weipub.scm
+
+TESTS = $(SCM_TESTS)
+
+EXTRA_DIST += $(TESTS)
+
+AM_TESTS_ENVIRONMENT = abs_top_srcdir="$(abs_top_srcdir)" GUILE_AUTO_COMPILE=0
+
+SCM_LOG_DRIVER = \
+ $(top_builddir)/pre-inst-env \
+ $(GUILE) --no-auto-compile -e main \
+ $(top_srcdir)/build-aux/test-driver.scm
+
+AM_SCM_LOG_DRIVER_FLAGS = --brief=yes
+
+EXTRA_DIST += \
+ pre-inst-env.in \
+ build-aux/test-driver.scm \
+ doc/fdl-1.3.texi
+
+# Handle substitution of fully-expanded Autoconf variables.
+do_subst = $(SED) \
+ -e 's,[@]GUILE[@],$(GUILE),g' \
+ -e 's,[@]GUILE_LOAD_COMPILED_PATH[@],$(GUILE_LOAD_COMPILED_PATH),g' \
+ -e 's,[@]GUILE_LOAD_PATH[@],$(GUILE_LOAD_PATH),g' \
+ -e 's,[@]guilemoduledir[@],$(guilemoduledir),g' \
+ -e 's,[@]guileobjectdir[@],$(guileobjectdir),g' \
+ -e 's,[@]abs_top_srcdir[@],$(abs_top_srcdir),g' \
+ -e 's,[@]abs_top_builddir[@],$(abs_top_builddir),g' \
+ -e 's,[@]localedir[@],$(localedir),g'
+
+dist-hook: $(distdir)/ChangeLog
+gen-ChangeLog $(distdir)/ChangeLog:
+ $(AM_V_GEN)if test -d .git; then \
+ $(top_srcdir)/build-aux/gitlog-to-changelog \
+ > $(distdir)/cl-t; \
+ rm -f $(distdir)/ChangeLog; \
+ mv $(distdir)/cl-t $(distdir)/ChangeLog; \
+ fi
+
+.PHONY: gen-ChangeLog
+
+CLEANFILES += \
+ $(SCM_TESTS:tests/%.scm=%.log)