summaryrefslogtreecommitdiff
path: root/modules/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'modules/configure.ac')
-rw-r--r--modules/configure.ac18
1 files changed, 18 insertions, 0 deletions
diff --git a/modules/configure.ac b/modules/configure.ac
new file mode 100644
index 0000000..5245123
--- /dev/null
+++ b/modules/configure.ac
@@ -0,0 +1,18 @@
+dnl -*- Autoconf -*-
+
+AC_INIT(python-on-guile, 0.1.0)
+AC_CONFIG_SRCDIR()
+AC_CONFIG_AUX_DIR([build-aux])
+AM_INIT_AUTOMAKE([color-tests -Wall -Wno-portability foreign])
+AM_SILENT_RULES([yes])
+AC_CONFIG_MACRO_DIR([m4])
+
+LT_INIT
+
+GUILE_PKG([3.0 2.2 2.1 2.0])
+GUILE_PROGS
+
+AC_CONFIG_FILES([Makefile])
+AC_CONFIG_FILES([env], [chmod +x env])
+AC_OUTPUT
+