summaryrefslogtreecommitdiff
path: root/modules/configure.ac
diff options
context:
space:
mode:
authorStefan Israelsson Tampe <stefan.itampe@gmail.com>2018-11-06 23:26:25 +0100
committerStefan Israelsson Tampe <stefan.itampe@gmail.com>2018-11-06 23:26:25 +0100
commit4d4de6eecb3917e19a0af616790630a683b43767 (patch)
tree84f4e249a986928dfcba616d32a269900804772c /modules/configure.ac
parent9f1bcefabfbfb28cd913b363285675d98e9c622c (diff)
python repo install
Diffstat (limited to 'modules/configure.ac')
-rw-r--r--modules/configure.ac18
1 files changed, 18 insertions, 0 deletions
diff --git a/modules/configure.ac b/modules/configure.ac
new file mode 100644
index 0000000..5245123
--- /dev/null
+++ b/modules/configure.ac
@@ -0,0 +1,18 @@
+dnl -*- Autoconf -*-
+
+AC_INIT(python-on-guile, 0.1.0)
+AC_CONFIG_SRCDIR()
+AC_CONFIG_AUX_DIR([build-aux])
+AM_INIT_AUTOMAKE([color-tests -Wall -Wno-portability foreign])
+AM_SILENT_RULES([yes])
+AC_CONFIG_MACRO_DIR([m4])
+
+LT_INIT
+
+GUILE_PKG([3.0 2.2 2.1 2.0])
+GUILE_PROGS
+
+AC_CONFIG_FILES([Makefile])
+AC_CONFIG_FILES([env], [chmod +x env])
+AC_OUTPUT
+