summaryrefslogtreecommitdiff
path: root/modules/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'modules/Makefile.am')
-rw-r--r--modules/Makefile.am11
1 files changed, 11 insertions, 0 deletions
diff --git a/modules/Makefile.am b/modules/Makefile.am
index 9d7ab54..f621dff 100644
--- a/modules/Makefile.am
+++ b/modules/Makefile.am
@@ -130,4 +130,15 @@ EXTRA_DIST += \
env.in \
COPYING
+python: python.in
+ $(SED) -e 's|[@]GUILE[@]|$(GUILE)|g' \
+ -e 's|[@]GUILE_EFFECTIVE_VERSION[@]|$(GUILE_EFFECTIVE_VERSION)|g' \
+ -e 's|[@]VERSION[@]|$(VERSION)|g' \
+ -e 's|[@]libdir[@]|$(libdir)|g' \
+ -e 's|[@]datadir[@]|$(datadir)|g' \
+ < "$^" > "$@.tmp"
+ mv "$@.tmp" "$@"
+
+CLEANFILES = python
+
nodist_bin_SCRIPTS = python