summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-10-27 23:28:37 +0200
committerRicardo Wurmus <rekado@elephly.net>2017-10-30 19:39:19 +0100
commitf8628b5f7f26847816b6052225fcd96031aed1a9 (patch)
tree2a57c7935a18bf62690e9eb0a1bf2971f7e1c08e /configure.ac
Initial commit.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac25
1 files changed, 25 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..a63c8d1
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,25 @@
+dnl -*- Autoconf -*-
+
+AC_INIT([mumi], [m4_translit(m4_esyscmd([cat VERSION]),m4_newline)])
+AC_CONFIG_AUX_DIR([build-aux])
+AM_INIT_AUTOMAKE([gnu color-tests -Wall -Wno-portability foreign])
+AM_SILENT_RULES([yes])
+
+GUILE_PKG([2.2])
+GUILE_PROGS
+if test "x$GUILD" = "x"; then
+ AC_MSG_ERROR(['guild' binary not found; please check your guile-2.2 installation.])
+fi
+
+
+guilemoduledir="${datarootdir}/guile/site/${GUILE_EFFECTIVE_VERSION}"
+AC_SUBST([guilemoduledir])
+AC_SUBST([GUILE_EFFECTIVE_VERSION])
+
+dnl Substitute placeholders to generate these target files
+AC_CONFIG_FILES([Makefile])
+AC_CONFIG_FILES([mumi/config.scm])
+AC_CONFIG_FILES([scripts/mumi], [chmod +x scripts/mumi])
+AC_CONFIG_FILES([pre-inst-env], [chmod +x pre-inst-env])
+
+AC_OUTPUT