summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorPaul van der Walt <paul@denknerd.org>2015-10-15 13:58:43 +0200
committerPaul van der Walt <paul@denknerd.org>2015-10-23 09:10:52 +0200
commit94e1dc7a57a4a1e4ab2003f04408e87088b25125 (patch)
treed7a90acbf2a7580b6c614ce3cef4dd44bb52118c /gnu
parent71470eddfa585b45b1de0d3c7e2ba058ea88c5a6 (diff)
gnu: Add ghc-blaze-builder.
* gnu/packages/haskell.scm (ghc-blaze-builder): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/haskell.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 9dea805abe..a2650ce159 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -1977,6 +1977,34 @@ of base to a wider range of compilers, without requiring the use of CPP
pragmas in your code.")
(license bsd-3)))
+(define-public ghc-blaze-builder
+ (package
+ (name "ghc-blaze-builder")
+ (version "0.4.0.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://hackage.haskell.org/package/blaze-builder/blaze-builder-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "1id3w33x9f7q5m3xpggmvzw03bkp94bpfyz81625bldqgf3yqdn1"))))
+ (build-system haskell-build-system)
+ (arguments `(#:tests? #f)) ; FIXME: Missing test libraries.
+ (propagated-inputs
+ `(("ghc-text" ,ghc-text)
+ ("ghc-utf8-string" ,ghc-utf8-string)))
+ (home-page "http://github.com/lpsmith/blaze-builder")
+ (synopsis "Efficient buffered output")
+ (description "This library provides an implementation of the older
+@code{blaze-builder} interface in terms of the new builder that shipped with
+@code{bytestring-0.10.4.0}. This implementation is mostly intended as a
+bridge to the new builder, so that code that uses the old interface can
+interoperate with code that uses the new implementation.")
+ (license bsd-3)))
+
(define-public ghc-easy-file
(package
(name "ghc-easy-file")