summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorPaul van der Walt <paul@denknerd.org>2015-10-15 01:14:29 +0200
committerPaul van der Walt <paul@denknerd.org>2015-10-23 09:10:52 +0200
commit10de4306d623cb01475653190e8aa8eafee3367b (patch)
tree0d39eb83ef76bb44f729ab0c009ff5c85218d2e0 /gnu
parent3410470d16c1295161f3cc54ba6ac801e3cee85a (diff)
gnu: Add ghc-uniplate.
* gnu/packages/haskell.scm (ghc-uniplate): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/haskell.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index cfa39acf15..b11b0de624 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -1375,6 +1375,32 @@ optimized for performance critical use, both in terms of large data quantities
and high speed.")
(license bsd-3)))
+(define-public ghc-uniplate
+ (package
+ (name "ghc-uniplate")
+ (version "1.6.12")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://hackage.haskell.org/package/uniplate/uniplate-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "1dx8f9aw27fz8kw0ad1nm6355w5rdl7bjvb427v2bsgnng30pipw"))))
+ (build-system haskell-build-system)
+ (propagated-inputs
+ `(("ghc-syb" ,ghc-syb)
+ ("ghc-hashable" ,ghc-hashable)
+ ("ghc-unordered-containers" ,ghc-unordered-containers)))
+ (home-page "http://community.haskell.org/~ndm/uniplate/")
+ (synopsis "Simple, concise and fast generic operations")
+ (description "Uniplate is a library for writing simple and concise generic
+operations. Uniplate has similar goals to the original Scrap Your Boilerplate
+work, but is substantially simpler and faster.")
+ (license bsd-3)))
+
(define-public ghc-base64-bytestring
(package
(name "ghc-base64-bytestring")