summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am76
1 files changed, 76 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..ba9876c
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,76 @@
+# Guile Picture Language --- Compose pictures with Guile
+# Copyright © 2019 Ricardo Wurmus <rekado@elephly.net>
+#
+# This file is part of the Guile Picture Language
+#
+# Guile-Debbugs is free software: you can redistribute it and/or
+# modify it under the terms of the GNU General Public License
+# as published by the Free Software Foundation, either version 3 of
+# the License, or (at your option) any later version.
+#
+# Guile-Debbugs is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# Affero General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with Guile-Debbugs. If not, see <http://www.gnu.org/licenses/>.
+
+include guile.am
+
+moddir=$(prefix)/share/guile/site/@GUILE_EFFECTIVE_VERSION@
+godir=$(libdir)/guile/@GUILE_EFFECTIVE_VERSION@/ccache
+
+SOURCES = \
+ pict.scm \
+ pict/base64.scm \
+ pict/sxml.scm
+
+EXTRA_DIST += \
+ env.in \
+ $(SCM_TESTS)
+
+info_TEXINFOS = doc/picture-language.texi
+
+DOC_IMAGES = $(addsuffix .svg.scm, $(addprefix $(top_srcdir)/doc/images/, \
+ line hline vline polyline polyline2 polygon boring-triangles modifiers))
+
+infoimagedir = $(infodir)/images
+dist_infoimage_DATA = \
+ $(DOC_IMAGES:%.scm=%.scm.png)
+
+%.svg.scm.svg: %.svg.scm
+ $(top_builddir)/env \
+ $(GUILE) --no-auto-compile -e main \
+ $(top_srcdir)/build-aux/generate-images.scm $(abs_top_srcdir)/$<
+
+%.svg.scm.png: %.svg.scm.svg
+ convert $< $@
+
+# We cannot add new dependencies to `%D%/picture-language.pdf' &
+# co. (info "(automake) Extending"). Using the `-local' rules is
+# imperfect, because they may be triggered after the main rule. Oh,
+# well.
+pdf-local: $(DOC_IMAGES)
+info-local: $(DOC_IMAGES)
+
+EXTRA_DIST += \
+ $(DOC_IMAGES) \
+ $(DOC_IMAGES:%.svg.scm=%.svg.scm.svg) \
+ doc/fdl-1.3.texi
+
+dist-hook: gen-ChangeLog
+gen-ChangeLog:
+ $(AM_V_GEN)if test -d .git; then \
+ $(top_srcdir)/build-aux/gitlog-to-changelog \
+ > $(distdir)/cl-t; \
+ rm -f $(distdir)/ChangeLog; \
+ mv $(distdir)/cl-t $(distdir)/ChangeLog; \
+ fi
+
+ps:
+dvi:
+install-ps:
+install-dvi:
+
+.PHONY: gen-ChangeLog install-dvi install-ps dvi ps