summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 45a10bc..e49e1ee 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -64,3 +64,13 @@ info_TEXINFOS = doc/guile-debbugs.texi
EXTRA_DIST += \
doc/fdl-1.3.texi
+dist-hook: $(distdir)/ChangeLog
+gen-ChangeLog $(distdir)/ChangeLog:
+ $(AM_V_GEN)if test -d .git; then \
+ $(top_srcdir)/build-aux/gitlog-to-changelog \
+ > $(distdir)/cl-t; \
+ rm -f $(distdir)/ChangeLog; \
+ mv $(distdir)/cl-t $(distdir)/ChangeLog; \
+ fi
+
+.PHONY: gen-ChangeLog