summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorArun Isaac <arunisaac@systemreboot.net>2018-10-02 02:01:59 +0530
committerRicardo Wurmus <rekado@elephly.net>2018-11-09 20:08:51 +0100
commit75a331d561c8b6f8efcf16216dab961c17759efe (patch)
treee42c71d98a678f2c24752970de537caa2add8bdb /configure.ac
parent3fc53d0e0db95f57bfa81d277ea3fbed68b73786 (diff)
Add guile-email dependency.
* configure.ac: Check for guile-email.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index e5095da..bee7220 100644
--- a/configure.ac
+++ b/configure.ac
@@ -29,6 +29,11 @@ if test "x$GUILD" = "x"; then
AC_MSG_ERROR(['guild' binary not found; please check your guile-2.2 installation.])
fi
+GUILE_MODULE_AVAILABLE([have_guile_email], [(email email)])
+if test "x$have_guile_email" != "xyes"; then
+ AC_MSG_ERROR([guile-email is missing; please install it.])
+fi
+
AC_CONFIG_FILES([Makefile])
AC_CONFIG_FILES([env], [chmod +x env])
AC_OUTPUT