summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-03-18 13:35:29 +0100
committerRicardo Wurmus <rekado@elephly.net>2021-03-18 13:35:29 +0100
commitfe7df8aa63856976730164562648622965c7b563 (patch)
treec9b0a7a8bb027e22cc0c44c44f52b43341a8f817 /Makefile.am
parentba29d0b6cb352169d3f961c40b301ccbcba96247 (diff)
Add serialization tests.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am22
1 files changed, 22 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 963ec6d..9276104 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -44,3 +44,25 @@ $(JSON_SOURCES:.normal.json=.go): %.go: %.normal.json aws/base.scm language/aws/
SOURCES = $(GUILE_SOURCES) $(JSON_SOURCES)
+
+TEST_EXTENSIONS = .scm
+
+SCM_TESTS = \
+ tests/serialize.scm
+
+TESTS = $(SCM_TESTS)
+
+EXTRA_DIST += $(TESTS)
+
+AM_TESTS_ENVIRONMENT = abs_top_srcdir="$(abs_top_srcdir)" GUILE_AUTO_COMPILE=0
+
+SCM_LOG_DRIVER = \
+ $(top_builddir)/pre-inst-env \
+ $(GUILE) --no-auto-compile -e main \
+ $(top_srcdir)/build-aux/test-driver.scm
+
+AM_SCM_LOG_DRIVER_FLAGS = --brief=yes
+
+EXTRA_DIST += \
+ pre-inst-env.in \
+ build-aux/test-driver.scm