summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-03-28 22:50:52 +0200
committerRicardo Wurmus <rekado@elephly.net>2021-03-28 22:50:52 +0200
commitf0a9929761c26e57f5c70b458de514e7499fe4ec (patch)
tree5937a1cba40d34ef18d9f3503d0bbaff850d4af6 /Makefile.am
parentfffdbcbb6b0cded52c9e33bec63ea2c4ce1a928c (diff)
Add support for Route 53 API.
* aws/api/route53-2013-04-01.normal.json: New API file. * Makefile.am (JSON_SOURCES): Add it. * aws/base.scm (aws-operation): Pass xml-namespace to requester. * aws/request.scm (request-xml-string): New procedure. (make-operation->request): Accept xml-namespace key. [host]: Use globalEndpoint if provided. [request-parameters]: Use request-xml-string for rest-xml protocol. * aws/serialize.scm (aws-value->sxml): New procedure. * language/aws/spec.scm (compile-operation): Pass xml-namespace to aws-operation.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 9276104..5348e40 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -35,7 +35,8 @@ JSON_SOURCES = \
aws/api/ecr-2015-09-21.normal.json \
aws/api/ecs-2014-11-13.normal.json \
aws/api/ec2-2016-11-15.normal.json \
- aws/api/s3-2006-03-01.normal.json
+ aws/api/s3-2006-03-01.normal.json \
+ aws/api/route53-2013-04-01.normal.json
$(JSON_SOURCES:.normal.json=.go): %.go: %.normal.json aws/base.scm language/aws/spec.scm
$(AM_V_GEN)$(top_builddir)/pre-inst-env $(GUILE_TOOLS) \