summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-06-29 01:51:57 +0200
committerRicardo Wurmus <rekado@elephly.net>2019-07-25 00:20:57 +0200
commitc9e1ea1d8cf2daab752b6073eeab5a328d7964ec (patch)
tree8458bc2f29f088cb651fb06b3f30785811d338ac /Makefile.am
Initial commit.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am41
1 files changed, 41 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..a497b4d
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,41 @@
+GOBJECTS = $(GUILE_SOURCES:%.scm=%.go) $(JSON_SOURCES:.normal.json=.go)
+
+nobase_mod_DATA = $(SOURCES) $(NOCOMP_SOURCES)
+nobase_go_DATA = $(GOBJECTS)
+
+# Make sure source files are installed first, so that the mtime of
+# installed compiled files is greater than that of installed source
+# files. See
+# <http://lists.gnu.org/archive/html/guile-devel/2010-07/msg00125.html>
+# for details.
+guile_install_go_files = install-nobase_goDATA
+$(guile_install_go_files): install-nobase_modDATA
+
+CLEANFILES = $(GOBJECTS)
+EXTRA_DIST = $(SOURCES) $(NOCOMP_SOURCES)
+GUILE_WARNINGS = -Wunbound-variable -Warity-mismatch -Wformat
+SUFFIXES = .scm .go
+.scm.go:
+ $(AM_V_GEN)$(top_builddir)/pre-inst-env $(GUILE_TOOLS) compile $(GUILE_WARNINGS) -o "$@" "$<"
+
+moddir=$(prefix)/share/guile/site/$(GUILE_EFFECTIVE_VERSION)
+godir=$(libdir)/guile/$(GUILE_EFFECTIVE_VERSION)/ccache
+
+GUILE_SOURCES = \
+ aws/base.scm \
+ aws/request.scm \
+ aws/utils/json.scm \
+ language/aws/spec.scm
+
+JSON_SOURCES = \
+ aws/api/cloudfront-2019-03-26.normal.json \
+ aws/api/ec2-2016-11-15.normal.json \
+ aws/api/s3-2006-03-01.normal.json
+
+$(JSON_SOURCES:.normal.json=.go): %.go: %.normal.json aws/base.scm language/aws/spec.scm
+ $(AM_V_GEN)$(top_builddir)/pre-inst-env $(GUILE_TOOLS) \
+ compile $(GUILE_WARNINGS) -O1 --from=aws \
+ -o "$@" "$<"
+
+
+SOURCES = $(GUILE_SOURCES) $(JSON_SOURCES)