summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 2442982..f24c741 100644
--- a/configure.ac
+++ b/configure.ac
@@ -11,6 +11,11 @@ if test "x$GUILD" = "x"; then
AC_MSG_ERROR(['guild' binary not found; please check your guile-2.2 installation.])
fi
+GUILE_MODULE_AVAILABLE([have_json], [(json)])
+if test "x$have_json" != "xyes"; then
+ AC_MSG_ERROR([Guile-JSON is missing; please install it.])
+fi
+
GUILE_MODULE_AVAILABLE([have_guile_debbugs], [(debbugs soap)])
if test "x$have_guile_debbugs" != "xyes"; then
AC_MSG_ERROR([Guile-Debbugs is missing; please install it.])