summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index a63c8d1..330b5f1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -11,6 +11,15 @@ if test "x$GUILD" = "x"; then
AC_MSG_ERROR(['guild' binary not found; please check your guile-2.2 installation.])
fi
+GUILE_MODULE_AVAILABLE([have_guile_debbugs], [(debbugs soap)])
+if test "x$have_guile_debbugs" != "xyes"; then
+ AC_MSG_ERROR([Guile-Debbugs is missing; please install it.])
+fi
+
+GUILE_MODULE_AVAILABLE([have_mailutils], [(mailutils mailutils)])
+if test "x$have_mailutils" != "xyes"; then
+ AC_MSG_ERROR([Guile bindings to mailutils are missing; please install them.])
+fi
guilemoduledir="${datarootdir}/guile/site/${GUILE_EFFECTIVE_VERSION}"
AC_SUBST([guilemoduledir])