summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am21
1 files changed, 21 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 1f54042..61ab603 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -52,3 +52,24 @@ SOURCES = \
mumi/debbugs.scm \
mumi/xapian.scm
+TEST_EXTENSIONS = .scm
+
+SCM_TESTS = \
+ tests/xapian.scm
+
+TESTS = $(SCM_TESTS)
+
+EXTRA_DIST += $(TESTS)
+
+AM_TESTS_ENVIRONMENT = abs_top_srcdir="$(abs_top_srcdir)" GUILE_AUTO_COMPILE=0
+
+SCM_LOG_DRIVER = \
+ $(top_builddir)/pre-inst-env \
+ $(GUILE) --no-auto-compile -e main \
+ $(top_srcdir)/build-aux/test-driver.scm
+
+AM_SCM_LOG_DRIVER_FLAGS = --brief=yes
+
+EXTRA_DIST += \
+ pre-inst-env.in \
+ build-aux/test-driver.scm