summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am40
1 files changed, 40 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..4cbec8d
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,40 @@
+# mumi - Mediocre, uh, mail interface
+# Copyright © 2016, 2017 Ricardo Wurmus <rekado@elephly.net>
+#
+# This file is part of mumi.
+#
+# mumi is free software; you can redistribute it and/or modify it
+# under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 3 of the License, or
+# (at your option) any later version.
+#
+# mumi is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with mumi. If not, see <http://www.gnu.org/licenses/>.
+
+include guile.am
+
+bin_SCRIPTS = \
+ scripts/mumi
+
+moddir = $(prefix)/share/guile/site/$(GUILE_EFFECTIVE_VERSION)
+godir = $(moddir)
+assetsdir = $(datadir)/@PACKAGE@
+
+SOURCES = \
+ mumi/web/server.scm \
+ mumi/web/render.scm \
+ mumi/web/controller.scm \
+ mumi/web/view/html.scm \
+ mumi/web/view/utils.scm \
+ mumi/web/sxml.scm \
+ mumi/web/util.scm \
+ mumi/messages.scm \
+ mumi/commands.scm \
+ mumi/config.scm \
+ mumi/queries.scm \
+ mumi.scm