summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2022-12-20 13:15:05 +0100
committerRicardo Wurmus <rekado@elephly.net>2022-12-20 13:15:05 +0100
commitd38e0af8b61ebd1ce5748a878eeb6158d0229671 (patch)
tree6594fa3a8db2ecb9a355bcda4986a7216b793460 /configure.ac
parent283251f84078fd53e816ee03ca64c40927ca7435 (diff)
Remove bootstrap.css and build CSS from SCSS sources.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac17
1 files changed, 17 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 22bfb71..3fac7da 100644
--- a/configure.ac
+++ b/configure.ac
@@ -5,6 +5,23 @@ AC_CONFIG_AUX_DIR([build-aux])
AM_INIT_AUTOMAKE([gnu color-tests -Wall -Wno-portability foreign])
AM_SILENT_RULES([yes])
+dnl Check for required programmes and store their full path in the
+dnl given variables. The variables are used to substitute
+dnl placeholders in the scripts.
+
+dnl The variables only need to be set manually when they cannot be
+dnl found via the PATH environment variable.
+AC_DEFUN([find_or_override_prog],
+[AC_ARG_VAR($1, override location of $2 executable)dnl
+AS_IF([test -z "$$1"],dnl
+ [AC_PATH_PROG([$1], [$2], no)dnl
+ if test x"$$1" == x"no" ; then
+ AC_MSG_ERROR([Could not find $2.])
+ fi
+ ],dnl
+ [AC_MSG_NOTICE([Using $$1 as $2 executable.])])])
+find_or_override_prog([SASSC], [sassc])
+
GUILE_PKG([3.0 2.2])
GUILE_PROGS
if test "x$GUILD" = "x"; then