summaryrefslogtreecommitdiff
path: root/testsuite/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'testsuite/Makefile.am')
-rw-r--r--testsuite/Makefile.am27
1 files changed, 27 insertions, 0 deletions
diff --git a/testsuite/Makefile.am b/testsuite/Makefile.am
new file mode 100644
index 000000000..d839ff349
--- /dev/null
+++ b/testsuite/Makefile.am
@@ -0,0 +1,27 @@
+# The test programs.
+
+# The Libtool executable.
+GUILE_VM = $(top_builddir)/src/guile-vm
+
+vm_test_files = \
+ t-basic-contructs.scm \
+ t-global-bindings.scm \
+ t-closure.scm \
+ t-closure2.scm \
+ t-closure3.scm \
+ t-do-loop.scm \
+ t-macros.scm \
+ t-macros2.scm \
+ t-proc-with-setter.scm \
+ t-values.scm \
+ t-records.scm \
+ t-match.scm \
+ t-mutual-toplevel-defines.scm
+
+EXTRA_DIST = run-vm-tests.scm $(vm_test_files)
+
+
+check:
+ $(GUILE_VM) -L $(top_srcdir)/module \
+ -l run-vm-tests.scm -e run-vm-tests \
+ $(vm_test_files)