summaryrefslogtreecommitdiff
path: root/libguile/Makefile.am
diff options
context:
space:
mode:
authorDavid Michael <fedora.dm0@gmail.com>2015-07-22 12:54:32 -0400
committerAndy Wingo <wingo@pobox.com>2016-05-22 19:50:27 +0200
commit41f28a9b0e7c1d60c3465fcbc25e40a77d59aa14 (patch)
tree30a698f258e6bde8471165557b976aab3cc97524 /libguile/Makefile.am
parentbefaad0c14d15d178caa5984cd32a8d64c536b32 (diff)
Remove SIGEV constant definitions.
* libguile/Makefile.am (chknew-E chknew-SIG): Anchor the end of the signal/error name pattern to only match alphanumeric symbols. * libguile/cpp-SIG.syms (SIGEV_MAX_SIZE, SIGEV_NONE): Remove. (SIGEV_PAD_SIZE, SIGEV_SIGNAL, SIGEV_THREAD): Likewise. (SIGEV_THREAD_ID): Likewise. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'libguile/Makefile.am')
-rw-r--r--libguile/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/libguile/Makefile.am b/libguile/Makefile.am
index ae546dd61..f6d7515df 100644
--- a/libguile/Makefile.am
+++ b/libguile/Makefile.am
@@ -821,7 +821,7 @@ chknew-E chknew-SIG:
echo "#include <$${bit}.h>" \
| sed 's/E/errno/;s/SIG/signal/' \
| gcc -dM -E - \
- | sed 's/^#define //;/^'$$bit'[0-9A-Z][0-9A-Z]*/!d;s/ .*//' \
+ | sed 's/^#define //;/^'$$bit'[0-9A-Z][0-9A-Z]* /!d;s/ .*//' \
| sort | diff -u $$old - | sed '1,2d;/^+/!d;s/^.//' \
> TMP ; \
if [ -s TMP ] ; then new="$$old.NEW" ; \