guix: Use latest version of guile-email.