configure: Check for Guile 3.0 first.
authorRicardo Wurmus <rekado@elephly.net>
Sat, 29 Feb 2020 07:47:10 +0000 (08:47 +0100)
committerRicardo Wurmus <rekado@elephly.net>
Sat, 29 Feb 2020 07:47:10 +0000 (08:47 +0100)
configure.ac

index f9875155a85efd38a422aaf7f4a904a57f66955d..6b25f63347d80ac9f2c1f1a295731dd4a4a82586 100644 (file)
@@ -5,10 +5,10 @@ AC_CONFIG_AUX_DIR([build-aux])
 AM_INIT_AUTOMAKE([gnu color-tests -Wall -Wno-portability foreign])
 AM_SILENT_RULES([yes])
 
-GUILE_PKG([2.2])
+GUILE_PKG([3.0 2.2])
 GUILE_PROGS
 if test "x$GUILD" = "x"; then
-   AC_MSG_ERROR(['guild' binary not found; please check your guile-2.2 installation.])
+   AC_MSG_ERROR(['guild' binary not found; please check your Guile installation.])
 fi
 
 GUILE_MODULE_AVAILABLE([have_json], [(json)])