libre: my/emacs: Use latest release tarball.
authorrekado <rekado@elephly.net>
Mon, 10 Oct 2016 05:09:53 +0000 (07:09 +0200)
committerrekado <rekado@elephly.net>
Mon, 10 Oct 2016 05:09:53 +0000 (07:09 +0200)
libre/custom/packages/variants.scm

index c600bd7..2fc2e6f 100644 (file)
 (define-public my/emacs
   (package
     (inherit emacs)
-    (version "25.1-rc2")
-    (source (origin
-              (method url-fetch)
-              (uri (string-append "ftp://alpha.gnu.org/gnu/emacs/pretest/emacs-"
-                                  version ".tar.xz"))
-              (sha256
-               (base32
-                "1hffvyvl50mrivdv6lp92sbxi3l2zhblj8npmpbzk47zpl1mzm2v"))
-              (patches (search-patches "emacs-exec-path.patch"
-                                       "emacs-source-date-epoch.patch"))))
     (arguments (append '(#:configure-flags '("--with-xwidgets=yes"
-                                             ;;"--with-cairo=yes"
-))
+                                             "--with-cairo=yes"))
                        (package-arguments emacs)))
     (inputs
-     `(;;("cairo" ,cairo)
-       ("webkitgtk+" ,webkitgtk-2.4)
+     `(("cairo" ,cairo)
+       ("webkitgtk+" ,webkitgtk)
        ("libxcomposite" ,libxcomposite)
        ,@(package-inputs emacs)))))