libre: my/emacs: Build with HTTPS support.
authorrekado <rekado@elephly.net>
Sat, 29 Oct 2016 11:39:03 +0000 (13:39 +0200)
committerrekado <rekado@elephly.net>
Sat, 29 Oct 2016 11:39:03 +0000 (13:39 +0200)
libre/custom/packages/variants.scm

index 2fc2e6f..3f1f5c5 100644 (file)
@@ -26,6 +26,7 @@
   #:use-module (gnu packages)
   #:use-module (gnu packages autotools)
   #:use-module (gnu packages emacs)
+  #:use-module (gnu packages gnome)
   #:use-module (gnu packages gtk)
   #:use-module (gnu packages guile)
   #:use-module (gnu packages libusb)
          ("texinfo" ,texinfo))))))
 
 (define-public my/emacs
-  (package
-    (inherit emacs)
-    (arguments (append '(#:configure-flags '("--with-xwidgets=yes"
-                                             "--with-cairo=yes"))
-                       (package-arguments emacs)))
-    (inputs
-     `(("cairo" ,cairo)
-       ("webkitgtk+" ,webkitgtk)
-       ("libxcomposite" ,libxcomposite)
-       ,@(package-inputs emacs)))))
+  (let ((commit "5edf76ba15fb012e9cb3112ee4a2c9ef4b02f20e")
+        (revision "1"))
+    (package (inherit emacs)
+      (name "emacs")
+      (version (string-append "25.1-" revision "." (string-take commit 9)))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "git://git.sv.gnu.org/emacs.git")
+                      (commit commit)))
+                (file-name (string-append name "-" version "-checkout"))
+                (sha256
+                 (base32
+                  "04vw0q21kwbwrhycj0vbfrhxyb2nycnnqlch4nhl03v473fsxri4"))))
+      (arguments
+       (substitute-keyword-arguments
+           (append '(#:tests? #f  ; tests fail in this development version
+                     #:configure-flags '("--with-xwidgets=yes"))
+                   (package-arguments emacs))
+         ((#:phases phases)
+          `(modify-phases ,phases
+             (add-after 'unpack 'autogen
+               (lambda _
+                 (zero? (system* "autoreconf" "-vif"))))))))
+      (inputs
+       `(("libxcomposite" ,libxcomposite)
+         ("webkitgtk+" ,webkitgtk)
+         ;; These two are needed to get HTTPS support in Webkit.
+         ("glib-networking" ,glib-networking)
+         ("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
+         ,@(package-inputs emacs)))
+      (native-inputs
+       `(("autoconf" ,autoconf)
+         ("automake" ,automake)
+         ,@(package-native-inputs emacs))))))